Increased request latency

Incident Report for Buildkite

Resolved

Service has returned to normal. We've identified a small number of malfunctioning workers in the API worker pool that were unable to handle requests. This caused some requests to time out. We have cycled the worker pool to ensure any affected workers are removed.
Posted Apr 25, 2025 - 11:39 UTC

Investigating

We're experiencing higher than usual request latency. We're currently investigating the issue, and will provide an update soon.
Posted Apr 25, 2025 - 10:57 UTC
This incident affected: Web, Agent API, REST API, and Job Queue.