Delays in Hosted Agents job dispatch

Incident Report for Buildkite

Resolved

Job dispatch for Hosted Agents is no longer experiencing delays.
Posted Sep 02, 2026 - 15:51 UTC

Monitoring

We are continuing to process through the backlog of delayed jobs and monitoring.
Posted Sep 02, 2026 - 15:43 UTC

Identified

We're beginning to see recovery with delayed job dispatch for Hosted Agents. We are currently working through the backlog of delayed jobs.
Posted Sep 02, 2026 - 15:29 UTC

Update

Our engineers are continuing to investigate an issue with delayed job dispatch for Hosted Agents. Job dispatch for self-hosted agents remains unaffected.
Posted Sep 02, 2026 - 15:16 UTC

Investigating

We're investigating an issue with job dispatch to our Hosted Agents.
Posted Sep 02, 2026 - 14:45 UTC
This incident affected: Hosted Agents (Hosted Agents, MacOS, Linux (ARM64), Linux (AMD64)).