Elevated latency in GraphQL and Rest APIs

Incident Report for Buildkite

Resolved

The incident has been resolved and everything is operating normally.
Posted May 06, 2025 - 09:17 UTC

Monitoring

The issue has been mitigated, and we are actively monitoring system performance to ensure stability.
Posted May 06, 2025 - 08:58 UTC

Identified

We have identified the source of latency, and are working on mitigating the impact.
Posted May 06, 2025 - 08:29 UTC

Investigating

We're currently investigating increased latency affecting our REST and GraphQL APIs, as detected by our monitoring systems.
Posted May 06, 2025 - 08:19 UTC
This incident affected: REST API.