Increased error rate for pipeline uploads

Incident Report for Buildkite

Resolved

A handful of customers were unable to upload pipelines containing steps with soft-failure configurations, resulting in failed builds. This bug has since been rolled back. Pipeline uploads are now working again as expected.
Posted Sep 29, 2025 - 06:45 UTC

Monitoring

We have identified a faulty deploy, and have performed a rollback to resolve the issue.
Posted Sep 29, 2025 - 06:23 UTC

Investigating

We've been alerted to an increased error rate for pipeline uploads, and are investigating the cause.
Posted Sep 29, 2025 - 06:06 UTC
This incident affected: Job Queue.