High job dispatch latency
Incident Report for Buildkite
Postmortem

This was one of five incidents with a common root cause. The post mortem is available here.

Posted Jun 23, 2022 - 07:42 UTC

Resolved
This incident has been resolved.
We continue to closely monitor and investigate the underlying causes.
Posted May 18, 2022 - 00:31 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 18, 2022 - 00:19 UTC
Update
Metrics are returning to normal, and we continue to monitor and investigate.
Posted May 18, 2022 - 00:14 UTC
Investigating
We are experiencing elevated latency in dispatching build jobs to agents.
Our engineers are investigating.
Posted May 18, 2022 - 00:07 UTC
This incident affected: Agent API and Job Queue.