Delayed processing of execution uploads

Incident Report for Buildkite

Resolved

We think the impact from the issue is over.
Posted Oct 01, 2025 - 06:28 UTC

Monitoring

We have determined the root cause and have fixed the issue. The system is now processing a backlog of execution data.
Posted Sep 30, 2025 - 22:12 UTC

Identified

We have identified an issue with processing uploads to Test Engine and are working on a fix.
Posted Sep 30, 2025 - 21:04 UTC

Investigating

We're investigating delayed processing of execution uploads in the ingestion pipeline. You may see partial data appearing for Runs and Tests in Test Engine.
Posted Sep 30, 2025 - 19:44 UTC
This incident affected: Test Engine (Ingestion).