Increased latency and error rates

Incident Report for Buildkite

Resolved

An increase in requests has lead to the API service being temporarily saturated. We have updated rate limits to ensure this doesn't re-occur and will add further resources if necessary
Posted May 04, 2026 - 06:30 UTC

Investigating

We're observing increased latency and error rates in the Agent API for a subset of our customers. We're currently investigating and will provide status updates as they become available.
Posted May 04, 2026 - 06:02 UTC
This incident affected: Agent API.