Issue processing pipeline uploads
Incident Report for Buildkite
Resolved
From UTC 18:26 to UTC 18:32 we observed a locking issue processing pipeline uploads. This caused increased latency handling pipeline uploads that also stopped other work from running in our background queues. This significantly increased latency on all background work for ~6 minutes, including dispatching jobs to agents and creating builds from webhooks. The issue is now resolved.
Posted Jun 08, 2023 - 19:03 UTC
This incident affected: Agent API.