Increased latency and error rates

Incident Report for Buildkite

Resolved

We have seen a full recovery of services.
Posted Jun 18, 2026 - 09:43 UTC

Monitoring

A fix has been deployed, services are recovering.
Posted Jun 18, 2026 - 09:17 UTC

Update

We've identified the issue, we're continuing working on rolling out a fix. Impact is restricted to the builds create API for a subset of tenants.
Posted Jun 18, 2026 - 08:59 UTC

Identified

We're seeing increased latency and error rates for a subset of our customers. We're currently investigating and will provide status updates as they become available.
Posted Jun 18, 2026 - 08:05 UTC
This incident affected: REST API (REST API).