We've confirmed all impact from this incident has been resolved.
Posted Aug 03, 2026 - 05:36 UTC
Monitoring
The fix has been fully deployed and we are seeing signs of recovery. All events impacted by this issue will be automatically retried. We are continuing to monitor the fix for stability.
Posted Aug 03, 2026 - 05:29 UTC
Update
We've identified that the impact is more widespread that we initially understood - scheduled builds as well as job dispatch. The fix that is rolling out now is expected to address all impact.
Posted Aug 03, 2026 - 05:22 UTC
Identified
We're experiencing latency with processing job dispatch, pipeline uploads and incoming webhooks. We have identified the cause and are rolling forward with a fix now.
Posted Aug 03, 2026 - 05:17 UTC
Investigating
We've spotted that something has gone wrong. We're currently investigating the issue, and will provide an update soon.