Slow Loading of Dashboard Pages

Incident Report for Buildkite

Resolved

This incident has been resolved.
Posted Jan 06, 2026 - 02:39 UTC

Monitoring

We've deployed a fix and verified that latency has improved. We are continuing to monitor.
Posted Jan 06, 2026 - 02:05 UTC

Identified

We've identified this issue. We're deploying a fix.
Posted Jan 06, 2026 - 01:43 UTC

Investigating

We've identified that the clusters index page performing poorly. We're currently investigating the issue, and will provide an update soon.
Posted Jan 06, 2026 - 01:07 UTC
This incident affected: Web.