For the last week we have been internally testing our agent traffic running on our new EKS infrastructure successfully. At 23:01 11 August 2026 UTC we started routing <1% of agent traffic for a small subset of our customer to this EKS infrastructure. Within that subset of customers, any that were using an agent version < 3.97.0 saw an error "failed to decode JSON response: invalid character '<' looking for beginning of value". These older agents crashed once they received that error, which for some customers triggered repeated agent cycling. We reverted the routing to EKS infrastructure at 03:25 UTC after being alerted to the issue.
Posted Aug 12, 2026 - 04:08 UTC
Monitoring
We have reverted the change which introduced the elevated error rate. We believe the issue to be resolved but will continue to monitor.
Posted Aug 12, 2026 - 03:27 UTC
Update
For a subset of customers, <1% of their Agent API traffic is experiencing issues. We are rolling back the change that caused this issue while we investigate it further.
Posted Aug 12, 2026 - 03:22 UTC
Identified
We're seeing increased latency and error rates for a subset of our customers. We're currently addressing the cause and will provide status updates as they become available.
Posted Aug 12, 2026 - 02:59 UTC
Investigating
We've spotted that something has gone wrong. We're currently investigating the issue, and will provide an update soon.