Increased dispatch latency

Incident Report for Buildkite

Resolved

The cause of pipeline upload failures and dispatch latency that was impacting some of our customers has been resolved.
Posted Feb 17, 2026 - 21:05 UTC

Update

We're seeing signs of recovery. Our team is continuing to monitor the situation.
Posted Feb 17, 2026 - 20:47 UTC

Update

We've identified that this issue is also impacting pipeline uploads for customers that are affected. This is an isolated issue and not all customers are experiencing impact.
Posted Feb 17, 2026 - 20:30 UTC

Investigating

Some customers are experiencing increased latency for jobs being assigned to agents. We are investigating and will provide an update in 30 minutes.
Posted Feb 17, 2026 - 20:09 UTC
This incident affected: Job Queue.