Delay in processing Test Engine results from S3

Incident Report for Buildkite

Resolved

This incident has been resolved.
Posted Jul 01, 2025 - 01:28 UTC

Update

We have resolved the issue and are working through the backlog of data. Some customers may see incomplete information in Test Engine, but rest assured all data will be fully processed and no data has been lost.
Posted Jun 30, 2025 - 23:42 UTC

Monitoring

We have identified an issue with processing test data uploaded via S3 and are now working through the backlog.
Posted Jun 30, 2025 - 19:30 UTC

Investigating

We are investigating an issue with Test Engine results uploaded via S3 not being processed. We will provide a further update in 30min
Posted Jun 30, 2025 - 19:14 UTC
This incident affected: Test Engine (Ingestion).