Increased latency and error rates for Agent API

Incident Report for Buildkite

Resolved

Between 00:05 - 00:34 UTC, a subset of customers experienced increased latency and timeout errors on the Agent API. This impacts job assignment. At peak impact, we saw an error rate of 1.3% of requests and job acceptance latency up to 53s.
Posted Jun 11, 2026 - 00:51 UTC

Investigating

We're observing increased latency and error rates for a subset of our customers on the Agent API. We're currently investigating and will provide status updates as they become available.
Posted Jun 11, 2026 - 00:32 UTC
This incident affected: Agent API.