Latency issues

Incident Report for Buildkite

Update

We continue to experience high latency on some services. We're continuing to identify root causes.
Posted Mar 03, 2026 - 23:21 UTC

Update

We're still experiencing latency issues for agent api and job dispatch. We continue to investigate and identify the root cause.
Posted Mar 03, 2026 - 22:41 UTC

Investigating

We're seeing elevated job dispatch latency and Agent API latency across multiple shards. We're investigating.
Posted Mar 03, 2026 - 21:51 UTC
This incident affects: Agent API and Job Queue.