Delayed notifications

Incident Report for Buildkite

Resolved

Notification latency for the affected shard is now under 5s.
Posted Jul 28, 2026 - 20:57 UTC

Identified

We are investigating delays to build and job notifications for a subset of customers.
Posted Jul 28, 2026 - 20:38 UTC
This incident affected: Notifications (GitHub Commit Status Notifications, Email Notifications, Slack Notifications, Webhook Notifications).