High Agent API latency

Incident Report for Buildkite

Resolved

This incident is now resolved. Database and Agent API performance has returned to normal.
Posted May 14, 2025 - 20:28 UTC

Monitoring

We've corrected the issue and are monitoring performance of the affected database shard.
Posted May 14, 2025 - 19:17 UTC

Identified

A bad database query plan is causing increased latency and timeouts for some organizations. We're working to correct the issue.
Posted May 14, 2025 - 19:12 UTC

Investigating

We're experiencing high Agent API latency for a subset of customers. We are working to identify the cause.
Posted May 14, 2025 - 19:08 UTC
This incident affected: Agent API.