Performance degradation
Incident Report for Buildkite
Resolved
We have identified and restricted the cause of the performance degradation, and performance has returned to normal. We'll be keeping an eye on things, but we do not expect any recurrence.
Posted Feb 04, 2021 - 07:02 UTC
Update
We are continuing to monitor and manage performance.
Posted Feb 04, 2021 - 05:27 UTC
Monitoring
We have identified some unusual customer activity which had an abnormal impact on load. The activity seems to be subsiding. We will reach out to the identified customers, and we have longer term strategies for addressing the particular load observed.
Posted Feb 04, 2021 - 01:00 UTC
Investigating
We are investigating reports of performance degradation across our APIs.
Posted Feb 04, 2021 - 00:33 UTC
This incident affected: Agent API, REST API, and Job Queue.