Unexpected agent disconnection for some customers

Incident Report for Buildkite

Resolved

This incident has been resolved.
Posted Aug 25, 2026 - 08:16 UTC

Update

Agent connectivity is recovered, but some agents are not reconnecting automatically after the earlier forced disconnects.
We recommend restarting agent service to make agents reconnect.
Posted Aug 25, 2026 - 07:42 UTC

Monitoring

At 06:04 UTC we deployed a defective request routing change to `agent-edge.buildkite.com`, which caused some customers' agents to abruptly disconnect.

At 06:09 UTC we noticed the problem, and immediately reverted the change. We began to observe recovery at 06:10 UTC, and are continuing to monitor.
Posted Aug 25, 2026 - 06:41 UTC
This incident affected: Agent API.