Github checkout failures
Incident Report for Buildkite
Resolved
This incident has been resolved.
Posted Dec 13, 2022 - 18:51 UTC
Update
We have been investigating the git checkout errors reported by multiple customers.

Checking out GitHub special Pull Request head (pull//head) is failing in many cases, either because the special head doesn't exist or it points to a stale commit.

However, we've noticed creating a build manually in the buildkite.com UI and specifying the branch name or a commit sha to successfully work.
Posted Dec 13, 2022 - 18:06 UTC
Identified
Github is having an Incident with Git Operations and Pull Requests https://www.githubstatus.com/

Manually triggering a build in our UI should mitigate this issue.
Posted Dec 13, 2022 - 17:45 UTC
Update
We are continuing to investigate this issue.
Posted Dec 13, 2022 - 17:28 UTC
Investigating
We are currently investigating reports of Github checkout failures
Posted Dec 13, 2022 - 17:21 UTC
This incident affected: SCM Providers (GitHub).