Delayed notifications

Incident Report for Buildkite

Resolved

Notifications continue to be delivered without delay for the previously affected subset of customers. This incident is resolved.
Posted May 04, 2026 - 19:36 UTC

Monitoring

Applied remediations have resolved the previous notification delays affecting a subset of our customers. We're continuing to monitor the affected services for stability.
Posted May 04, 2026 - 18:54 UTC

Identified

We've identified the source of the notification delays affecting a subset of our customers. Our engineers are applying remediations to reduce these delays.
Posted May 04, 2026 - 18:06 UTC

Investigating

We are investigating delays with build and job notifications for a subset of customers.
Posted May 04, 2026 - 17:02 UTC
This incident affected: Notifications (GitHub Commit Status Notifications, Email Notifications, Slack Notifications, Webhook Notifications).