Elevated ingestion latency for Test Engine

Incident Report for Buildkite

Resolved

Processing of test execution ingestion data has successfully caught up.
Posted Mar 07, 2026 - 01:05 UTC

Monitoring

We've identified the issue and the system is currently processing the backlog of test executions
Posted Mar 07, 2026 - 00:56 UTC

Investigating

We are investigating the elevated latency issue for Test Engine. Processing the backlog of test executions is taking longer than expected, so elevated ingestion latency remains.
Posted Mar 07, 2026 - 00:21 UTC
This incident affected: Test Engine (Ingestion).