Jobs not starting on hosted agents and agent-stack-k8s

Incident Report for Buildkite

Resolved

We've reverted a change that caused stale environment variables provided to acquire job used in Hosted Agents, agent-stack-k8s and other agent implementations using acquire job.
Posted May 07, 2026 - 09:37 UTC

Identified

We're currently seeing recovery at 50% rate. We'll provide next update soon.
Posted May 07, 2026 - 09:24 UTC

Update

We've identified issue with job acquiring endpoint. We're rolling back now. We'll provide next update in ~20 minutes.
Posted May 07, 2026 - 09:09 UTC

Investigating

We've spotted that something has gone wrong. We're currently investigating the issue with new builds not starting.
Posted May 07, 2026 - 08:48 UTC
This incident affected: Agent API.