Build failures and decreased performance
Incident Report for Buildkite
Resolved
We identified a routine database index creation task which created unexpected problems, and caused problems with build creation and job allocation. The task was identified and stopped, and performance returned to normal. We'll continue to investigate how the task caused unexpected problems, and ways of preventing this from reoccurring.
Posted Dec 02, 2019 - 13:52 AEDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 02, 2019 - 13:17 AEDT
Identified
We're investigating issues with build creation failures and agent job allocation.
Posted Dec 02, 2019 - 13:13 AEDT
This incident affected: Web, REST API, and Job Queue.