Increased latency for REST API

Incident Report for Buildkite

Resolved

This incident has been resolved.
Posted Jan 31, 2024 - 03:23 UTC

Monitoring

REST API latency has returned to normal levels. We continue to monitor the situation.
Posted Jan 31, 2024 - 01:52 UTC

Update

We have seen a drop in request latency due to our increase in resource allocation. We are allocating further resources in order to reduce latency to normal levels.
Posted Jan 31, 2024 - 01:47 UTC

Identified

We have identified an increased number of requests to a particular endpoint and are working to mitigate the impact of the additional load. We have increase the available resources and continue to work on further mitigations.
Posted Jan 31, 2024 - 01:44 UTC

Investigating

We are currently investigating an issue of increased load on our REST API. The increase in load is causing elevated latency and request timeouts for some users.
Posted Jan 31, 2024 - 01:22 UTC
This incident affected: REST API.