Ongoing AWS incident

Incident Report for Buildkite

Resolved

With the recovery of service within AWS, we are treating this incident as resolved. Customers running their agents in AWS may experience lingering issues as service within the region stabilizes.
Posted Oct 20, 2025 - 11:52 UTC

Update

We're seeing signs of recovery from AWS. Build notifications may be delayed due to this incident and the flow on effect to other providers but are now being delivered successfully.
Posted Oct 20, 2025 - 09:53 UTC

Monitoring

We are continuing to track an incident with AWS' us-east-1 region, though impact to Buildkite's services appears to be minimal.
Posted Oct 20, 2025 - 09:22 UTC

Investigating

We're tracking an ongoing incident with an upstream provider, and are investigating any impact on Buildkite's services.
Posted Oct 20, 2025 - 08:38 UTC