Delayed Test Engine ingestion processing

Incident Report for Buildkite

Resolved

Processing of the backlog is complete.
Posted May 15, 2026 - 07:35 UTC

Monitoring

Ingestion of Test Engine execution data from an internal queue to a data store stalled, has been resumed, and is working through the backlog. Visibility of test executions from the past hour hours will be delayed for approximately a further one hour.

This has been a recurring issue; an architectural change is coming soon to eliminate this failure mode.
Posted May 15, 2026 - 06:51 UTC
This incident affected: Test Engine (Ingestion).