Test Engine: Delayed processing of test result ingestion

Incident Report for Buildkite

Resolved

Processing of test execution ingestion data has successfully caught up.
Posted May 06, 2026 - 05:26 UTC

Monitoring

We've identified the issue and the system is currently processing the backlog of test executions
Posted May 06, 2026 - 04:21 UTC

Investigating

A process writing test results to our Test Engine data store stalled, we've restarted the process and are seeing it catching up. We expect to be fully caught up on the backlog within the next couple of hours.
Posted May 06, 2026 - 03:57 UTC
This incident affected: Test Engine (Ingestion).