Slow web UI

Incident Report for Buildkite

Resolved

This incident has been resolved.
Posted Aug 11, 2026 - 02:04 UTC

Update

The integration between Pipelines and Test Engine has been re-enabled, restoring the Tests tab on build pages. We’re monitoring the recovery to confirm the integration remains stable. Test results continue to be available directly through Test Engine.
Posted Aug 11, 2026 - 01:04 UTC

Update

The integration between Pipelines and Test Engine remains temporarily disabled,  and we're actively working to bring this back online. This affects the Tests tab on build pages. We’ll provide another update as recovery progresses. Test results are available directly through Test Engine
Posted Aug 11, 2026 - 00:50 UTC

Monitoring

We have identified and fixed the issue. We are monitoring and seeing signs of improvement. We've temporarily disabled the integration between Pipelines and Test Engine. This affects the Tests tab on build pages. We’ll provide another update as recovery progresses. Test results are available directly through Test Engine
Posted Aug 10, 2026 - 23:55 UTC

Identified

We've identified the cause of the issue and are actively mitigating.
Posted Aug 10, 2026 - 23:25 UTC

Update

Our Web UI is slow at the moment, we are investigating the issue.
Posted Aug 10, 2026 - 23:14 UTC

Investigating

We've spotted that something has gone wrong and there's elevated latency. We're currently investigating the issue, and will provide an update soon.
Posted Aug 10, 2026 - 23:00 UTC
This incident affected: Web and Test Engine (Web).