Error spike on Test Engine pages API endpoints

Incident Report for Buildkite

Resolved

We’ve been monitoring this issue, and everything is stable and working properly.
Posted Jul 01, 2025 - 00:03 UTC

Monitoring

The issue has been resolved, and we are monitoring to ensure everything is functioning properly.
Posted Jun 30, 2025 - 23:35 UTC

Investigating

We've spotted an error spike on Test Engine pages and API endpoints.
Posted Jun 30, 2025 - 23:09 UTC
This incident affected: Test Engine (Web, REST API).