Delivery issues with email notifications

Incident Report for Buildkite

Resolved

Our outbound email queue has finished processing all previously failed deliveries. Email notifications are processing successfully.
Posted Sep 01, 2026 - 16:52 UTC

Monitoring

We are seeing successful email deliveries and are monitoring processing of our outbound email queue.
Posted Sep 01, 2026 - 16:38 UTC

Update

Our on-call engineers are working on failing over to an alternative upstream email provider to restore outbound email notifications. No other Buildkite services have been impacted by this disruption.
Posted Sep 01, 2026 - 16:19 UTC

Identified

We are experiencing delivery issues with email notifications due to an issue with an upstream provider.
Posted Sep 01, 2026 - 15:32 UTC
This incident affected: Notifications (Email Notifications).