Delays with GitHub Webhooks

Incident Report for Buildkite

Resolved

This incident has been resolved.
Posted Feb 03, 2026 - 18:44 UTC

Update

We’re seeing improvements with webhook delivery from GitHub, and we continue to monitor the issue.
Posted Feb 03, 2026 - 18:15 UTC

Monitoring

We're continuing to see delays in webhook delivery from GitHub, which may result in delays in Builds triggering and Commit Status updates.
Posted Feb 03, 2026 - 17:05 UTC

Update

We are continuing to investigate this issue.
Posted Feb 03, 2026 - 16:20 UTC

Investigating

We are currently investigating delays with receiving Webhooks from GitHub.
Posted Feb 03, 2026 - 15:36 UTC
This incident affected: Notifications (GitHub Commit Status Notifications) and Job Queue, Hosted Agents.