Increased latency and error rates

Incident Report for Buildkite

Resolved

We believe the impact from the issue is over, but we will continue monitoring today.
Posted Nov 12, 2025 - 22:28 UTC

Monitoring

Latency has improved and we are continuing to monitor.
Posted Nov 12, 2025 - 20:34 UTC

Update

We’ve isolated a poorly performing backend system and are seeing a small improvement, and are now working on improving processing the backlog of log uploads.
Posted Nov 12, 2025 - 20:23 UTC

Investigating

We're observing increased latency and error rates for a subset of our customers. We're currently investigating and will provide status updates as they become available.
Posted Nov 12, 2025 - 20:05 UTC
This incident affected: Agent API.