Increased latency on REST and GraphQL APIs

Incident Report for Buildkite

Resolved

The mitigation applied before the last update had the intended effect, and we have seen recovery in REST API latency.
Posted Jun 12, 2026 - 00:16 UTC

Update

We've isolated the issue to elevated load on our REST API service and have mitigated the issue. The agent and stacks API isn’t affected.
Posted Jun 11, 2026 - 23:51 UTC

Monitoring

We've isolated the issue to elevated load on our REST API service and are working to mitigate. The agent and stacks API isn’t affected.
Posted Jun 11, 2026 - 23:49 UTC

Investigating

We're observing increased latency for all our customers. We're currently investigating and will provide status updates as they become available.
Posted Jun 11, 2026 - 23:18 UTC
This incident affected: REST API (REST API, Remote MCP Server).