Increased dispatch latency

Incident Report for Buildkite

Resolved

This incident is now resolved.
Posted Jan 16, 2026 - 03:46 UTC

Monitoring

Between 02:30 UTC and 03:13 UTC we observed an increase in latency dispatching jobs in concurrency groups for some customers.

We've identified a code change which modified a critical query in selecting jobs in a concurrency group, and disabled the associated feature flag. This appears to have resolved the issue, but we will continue to monitor.
Posted Jan 16, 2026 - 03:42 UTC
This incident affected: Job Queue.