Delayed Test Engine results

Incident Report for Buildkite

Resolved

The backlog of Test Engine uploads have been fully processed. Recent test results are now appearing in Test Engine.
Posted Jun 17, 2025 - 00:46 UTC

Monitoring

A fix has been shipped and the backlog of recent Test Engine uploads are being processed. We are monitoring the recovery.
Posted Jun 17, 2025 - 00:24 UTC

Identified

We've spotted that something has gone wrong with Test Engine result uploads.
We have identified the issue and are working on a fix. All requests will processed eventually as there is no data loss. There is a backlog we will have to work through so Test Engine results will be delayed.
Posted Jun 16, 2025 - 23:06 UTC
This incident affected: Test Engine (Ingestion).