Increased latency for secrets endpoints for some customers

Incident Report for Buildkite

Resolved

Response times have returned to normal. This incident is now resolved.
Posted Feb 26, 2026 - 02:44 UTC

Monitoring

We've increased the compute available to the secrets service, and have seen response times return to normal levels.
Posted Feb 26, 2026 - 00:53 UTC

Investigating

We're observing increased latency on secrets endpoints for a subset of our customers. We're currently investigating and will provide status updates as they become available.
Posted Feb 26, 2026 - 00:43 UTC
This incident affected: Agent API.