504 errors viewing builds

Incident Report for Buildkite

Resolved

The incident is now resolved. We are no longer seeing errors when viewing pipelines.
Posted Mar 27, 2026 - 08:53 UTC

Monitoring

The deploy to revert this change is complete and builds are loading normally. We will continue to monitor for any other issues.
Posted Mar 27, 2026 - 08:08 UTC

Identified

We've identified a change which we think is the cause of this issue, and we're in the process of reverting it.
Posted Mar 27, 2026 - 07:18 UTC

Investigating

We're seeing an increase in 504 errors when viewing pipeline builds. We're investigating this now.
Posted Mar 27, 2026 - 07:02 UTC
This incident affected: Web.