Delayed notifications

Incident Report for Buildkite

Resolved

The incident is resolved
Posted May 20, 2026 - 17:39 UTC

Monitoring

We are seeing recovery across affected customers and continue to monitor
Posted May 20, 2026 - 17:26 UTC

Identified

We have identified the issue and applied mitigations and are monitoring recovery

We have determined that only a subset of customers are affected by the notification latency.
Posted May 20, 2026 - 17:06 UTC

Investigating

We are investigating delays to notifications across all customers
Posted May 20, 2026 - 16:40 UTC
This incident affected: Notifications (GitHub Commit Status Notifications, Email Notifications, Slack Notifications, Webhook Notifications).