Elevated ingestion latency for Test Engine

Incident Report for Buildkite

Resolved

Processing of test execution ingestion data has successfully caught up.
Posted Mar 04, 2026 - 12:35 UTC

Update

Processing the backlog of test executions is taking longer than expected, so elevated ingestion latency remains.
We continue to monitor progress.
We have also identified database schema improvements we can make that will increase throughput to avoid this scenario in future.
Posted Mar 04, 2026 - 08:00 UTC

Monitoring

We've identified and fixed the root cause and now monitoring the issue. Test execution may be delayed for up to 30 minutes.
Posted Mar 04, 2026 - 03:59 UTC
This incident affected: Test Engine (Ingestion).