Slow artifact uploads

Incident Report for Buildkite

Resolved

With artifact upload latency continuing to be stable, we are resolving this incident.
Posted Mar 06, 2026 - 10:23 UTC

Monitoring

Latency for artifact uploads has remained at normal levels for some time now, and we now have a mitigation in place for a common source of load going forward. We are continuing to monitor.
Posted Mar 06, 2026 - 08:02 UTC

Investigating

We're investigating slow artifact uploads. This is isolated to artifacts, dispatch remains unaffected.
Posted Mar 05, 2026 - 22:14 UTC
This incident affected: Agent API.