High dispatch latency for hosted agents

Incident Report for Buildkite

Resolved

This incident is now resolved.
Posted Aug 01, 2025 - 16:50 UTC

Identified

Unexpected load in an upstream database caused a period of high latency for hosted agent dispatch.
Posted Aug 01, 2025 - 16:50 UTC

Update

Service status remains operational. We are working with our hosting partner to identify the root cause.
Posted Aug 01, 2025 - 16:33 UTC

Update

System performance has returned to normal. We are still working to identify the root cause.
Posted Aug 01, 2025 - 15:48 UTC

Investigating

We're experiencing high job dispatch latency for hosted agents. We're working to identify the root cause.
Posted Aug 01, 2025 - 15:37 UTC
This incident affected: Hosted Agents.