Hosted Agents - Increased latency and error rates

Incident Report for Buildkite

Resolved

Jobs running on Hosted Agents are now being dispatched promptly.
Posted Sep 04, 2026 - 02:39 UTC

Monitoring

We have deployed mitigations and have observed recovery across Hosted Agents. We will continue monitoring.
Posted Sep 04, 2026 - 02:23 UTC

Investigating

We're seeing increased latency and error rates within our Hosted Agents. We're currently investigating and will provide status updates as they become available.
Posted Sep 04, 2026 - 01:42 UTC
This incident affected: Hosted Agents (Hosted Agents, MacOS, Linux (ARM64), Linux (AMD64)).