Service degredation with flaky test detection

Incident Report for Buildkite

Resolved

Flaky test detection has returned to normal operation and processing is no longer delayed.
Posted Jul 30, 2025 - 11:10 UTC

Monitoring

We have identified and rectified the cause of this delay. The system is now working through the backlog of flaky test data.
Posted Jul 30, 2025 - 10:41 UTC

Investigating

We are observing delays in processing flaky test detection and are currently investigating.
Posted Jul 30, 2025 - 09:29 UTC
This incident affected: Test Engine (Web, Ingestion).